System requirements

An internet connection – broadband wired or wireless (3G or 4G/LTE)
Speakers and a microphone – built-in, USB plug-in, or wireless Bluetooth

Supported operating systems

macOS X with macOS X (10.10) or later
Windows 11*
*Note: Windows 11 is supported on version 5.9.0 or higher.
Windows 10*
*Note: Devices running Windows 10 must run Windows 10 Home, Pro, or Enterprise. S Mode is not supported.
Windows 8 or 8.1
Windows 7
Ubuntu 12.04 or higher
Mint 17.1 or higher
Red Hat Enterprise Linux 6.4 or higher
Oracle Linux 6.4 or higher
CentOS 6.4 or higher
Fedora 21 or higher
OpenSUSE 13.2 or higher
ArchLinux (64-bit only)

Supported browsers

Windows: Edge 12+, Firefox 27+, Chrome 30+
macOS: Safari 7+*, Firefox 27+, Chrome 30+
Linux: Firefox 27+, Chrome 30+

*Some features of the Compliance Dashboard may not be compatible.

To complete and order through your distributor, please call Compliance Training Partners at 888.388.4782 and have your distributor information and account number available. If you’d like to complete your purchase with a credit card, please close this message, select "No Distributor", and enter your credit card information.
Scroll to Top